Page 1 of 1

Server links in menu creating errors from main page

Posted: 25 Mar 2016, 13:55
by gammeloni
Hello :)

Just signed up yesterday, so maybe it's actually a permission problem for the moment. However here is how to reproduce the error for me:
  • Set up a couple of servers under http://dayz-ast.com/server/list
  • Make sure you're set up as admin for the new server(s)
  • Make sure admin permissions are set to "full access" under permission group
  • Go back to main page: http://dayz-ast.com/
  • Select one of the new servers from the drop down menu in "servers"
  • Click on them and it will stay on the main page with a red error message on top saying "You don't have permission to perform this action." (It generates links like this one: http://dayz-ast.com/?_fid=19vm. However the links are correct when hovering over them in the menu http://dayz-ast.com/server/view/XY).
The only way I can actually access the servers is by clicking on the main menu entry and then on the right hand side submenu with "List" and then clicking on the links on the control panel content.

Re: Server links in menu creating errors from main page

Posted: 25 Mar 2016, 14:04
by TheKronnY
Hello, sorry for this bug and thanks for the detailed report! :)
I've fixed it and updated to the newest version, so it should work properly now. The old link got stuck there :lol:

If you ever find more bugs, feel free to let me know in this forum! ;)

Re: Server links in menu creating errors from main page

Posted: 25 Mar 2016, 15:42
by gammeloni
Thank you very much - that was some super fast work :D ! Have a great day/weekend